Melakukan Blok Situs Facebook Pada Mikrotik

Courtesy of Fai Mawaridz

Saat ini siapa sih yang nggak kenal dengan Facebook?? Situs jejaring yang banyak digunakan oleh orang-orang untuk mencari teman, chatting, dan sebagainya. Namun ternyata situs tersebut juga menjadi hambatan bagi perusahaan untuk melakukan kegiatan bisnisnya. Kenapa?? Salah satu penyebabnya adalah menjadikan para karyawannya
sibuk facebook-an, sehingga melupakan tugas-tugas pokoknya. Tidak terkecuali kantor dimana w bekerja menjadi korban demam facebook yang menjangkiti para karyawannya. Suatu hari w diminta oleh Pak Bos untuk memblokir situs Facebook,, Twitter and Youtube agar tidak bisa diakses oleh para karyawan di kantor selama jam kerja, sedangkan diluar jam kerja diijinkan untuk mengakses situs tersebut. Berhubung w menggunakan MikroTik sebagai router, maka w akan berbagi tips pemblokiran ala MikroTik. Berikut ini langkah-langkahnya. Semoga bermanfaat men ….

Pertama, supaya waktu yang berjalan di router sesuai dengan waktu lokasi setempat, maka kita perlu mengatur agar clock di MikroTik mengacu pada NTP Server. Jika kita memiliki NTP Server sendiri, maka kita tinggal mengarahkan MikroTik ke NTP Server tersebut, namun jika kita tidak memiliki NTP Server, maka tidak perlu khawatir karena banyak NTP Server di luar yang bisa kita gunakan sebagai acuan. Beberapa diantaranya adalah NTP Server milik LIPI (Lembaga Ilmu Pengetahuan Indonesia) dengan URL:

ntp.kim.lipi.go.id (203.160.128.6)

dan NTP Pool Project dengan salah satu URLnya:

0.id.pool.ntp.org (202.169.224.16)

Untuk mensettingnya di MikroTik, ketikkan perintah
berikut :

/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes;

Kedua, membuat rule di firewall filter. Dalam hal ini w ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut :

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dstport=80 content=”facebook” action=drop comment=”Blokir Akses Facebook”;

Ketiga, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini w membuat 3 script, yaitu script untuk mengaktifkan (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini
scriptnya :
Script untuk mematikan (disable) firewall :

/system script add name=”fb-allow” policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content=”facebook”] disabled=yes}

Script untuk mengaktifkan (enable) firewall :

/system script add name=”fb-deny” policy=write,read,policy,test,sniff source={/ip
firewall filter set [/ip firewall filter find content=”facebook”] disabled=no}

Script untuk disable firewall di hari libur dan enable di hari kerja :

/system script add name=”fb-holiday” policy=write,read,policy,test,sniff source={:if
([/system scheduler get [/system scheduler find on-event=”fb-deny”] disabled] =
true) do [/system scheduler set [/system scheduler find on-event=”fb-deny”]
disabled=no] else [/system scheduler set [/system scheduler find on-event=”fbdeny”]
disabled=yes]}

Keempat, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini w membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00, jam 12:00, jam 13:00, jam 17:00, hari sabtu-minggu, dan hari senin. Berikut ini scriptnya Schedule untuk mematikan (disable) firewall pada jam kerja (08:00)
:

/system scheduler add name=”fb-08:00″ start-date=jan/01/2010 starttime=08:00:00 interval=1d on-event=”fb-allow”

Schedule untuk mengaktifkan (enable) firewall pada jam istirahat (12:00) :

/system scheduler add name=”fb-12:00″ start-date=jan/01/2010 starttime=12:00:00 interval=1d on-event=”fb-deny”

Schedule untuk mematikan kembali (disable) firewall pada jam kerja (13:00) :

/system scheduler add name=”fb-13:00″ start-date=jan/01/2010 starttime=13:00:00 interval=1d on-event=”fb-allow”

Schedule untuk mengaktifkan (enable) firewall di luar jam kerja ke atas ( > 17:00) :

/system scheduler add name=”fb-17:00″ start-date=jan/01/2010 starttime=17:00:00 interval=1d on-event=”fb-deny”

Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :

/system scheduler add name=”fb-sabtu-minggu” start-date=jan/06/2010 starttime=00:00:00 interval=7d on-event=”fb-holiday”

( Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler
adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.)
Schedule untuk mengaktifkan kembali (enable) firewall di hari kerja (Senin) :

/system scheduler add name=”fb-senin” start-date=jan/08/2010 starttime=00:00:00 interval=7d on-event=”fb-holiday”

( Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler
adalah Hari Senin. Dan parameter “interval” diberi nilai 7d. )
Untuk situs Twitter and Youtube bisa dilakukan hal yg sama dengan merubah nama
facebook menjadi twitter / youtube,
Ext :
facebook = fb-allow/fb-deny
twiiter = tw-allow/tw-deny.

3 Comments

  1. nice post,,
    thankz gan,,
    ๐Ÿ˜€

    • wahahaha…
      thanks juga gan udah dikasih ijin share๐Ÿ˜€

  2. wah keren gan, cuman karna saya masih pemula bgt, saya gak ngerti bgt neh, cara pakainya,…๐Ÿ˜›
    klo bisa tolong di rincikan dan di kirim ke email saya, makasih gan..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: